Wireshark-dev: Re: [Wireshark-dev] Attempted to build NSIS installer for 2.6.3
From: Graham Bloice <[email protected]>
Date: Tue, 2 Oct 2018 08:38:41 +0100


On Mon, 1 Oct 2018 at 18:57, John Dill <[email protected]> wrote:
I'm trying to build an installer for Wireshark 2.6.3 on Windows using NSIS and I'm getting the following when I run

msbuild /m /p:Configuration=RelWithDebInfo nsis_package.vcxproj

Here is the commands I used before hand:

set CYGWIN=nodosfilewarning
set WIRESHARK_LIB_DIR=C:\Wireshark-win64-libs-2.6
set PLATFORM=win64
set QT5_BASE_DIR=C:\Qt\Qt5.8.0\5.8\msvc2015_64


Note that the release builds of 2.6 are built using Qt 5.9.5, although this isn't likely to be your issue.
 
cd wsbuild64

cmake -G "Visual Studio 14 2015 Win64" ..\wireshark-src
msbuild /m /p:Configuration=RelWithDebInfo /p:Platform=x64 Wireshark.sln (... ok ...)

Again note that the release builds of 2.6 are built using VS 2017, again not likely to be your issue.  The Developers Guide is out of date here, still showing VS 2015.
 

msbuild /m /p:Configuration=RelWithDebInfo nsis_package_prep.vcxproj (... ok ...)
msbuild /m /p:Configuration=RelWithDebInfo nsis_package.vcxproj

...
        Processing config: C:\Program Files (x86)\NSIS\nsisconf.nsh
        File: "C:\Users\DillJA\Desktop\wsbuild64\docbook\user-guide.chm" -> no files found.
        Usage: File [/nonfatal] [/a] ([/r] [/x filespec [...]] filespec [...]
              /_oname_=outfile one_file_only)
        Error in script "wireshark.nsi" on line 1173 -- aborting creation process

Then it errors out with Build FAILED.

I noticed that I can finish the NSIS installer script if I comment out the USER_GUIDE_DIR section, but I'm trying to install the right packages and can't seem to get this error to go away without modifying the wireshark.nsi script.

I notice in the cmake that the build script can't find asciidoctor even though ruby is installed on Cygwin64, and if I do a 'gem list --local', I see 'asciidoctor (1.5.7.1)'.

I tried to look for the packages asciidoctor in setup_x86_64.exe for Cygwin and couldn't find asciidoctorj, xsltproc, and docbook-bundle.

Can someone familiar with the Windows build offer some hints?  Do I need to switch from Cygwin to Chocolatey (which I haven't tried yet)?


To build an NSIS installer does require the documentation to be built, and this requires various bits of toolchain, hopefully all described in the Developers Guide.  The release buildbots use the Chocolatey Asciidoctorj package as described in the Developers Guide sect. 2.2.8.  I think you will also need to install the Microsoft HTML Help Compiler, this seems to have been erroneously removed from the docs, try here: https://www.microsoft.com/en-us/download/details.aspx?id=21138

If you still have issues, please re-run the CMake configuration step, redirecting the output to a file, e.g. "cmake ... > cmakeout.txt 2>&1" and then post the file.

You can use the buildbot output to cross check against your installation, especially the CMake configuration step over here: https://buildbot.wireshark.org/wireshark-2.6/waterfall

--
Graham Bloice