Wireshark-dev: [Wireshark-dev] extcap command line parameter format
From: Jaap Keuter <[email protected]>
Date: Fri, 20 Jul 2018 19:12:00 +0200
Hi,

While having reviewed extcap documentation [Ref1] I was triggered by bug 14982 [Ref2] (usbpcap no longer recognized in 2.9) concerning the addition of --extcap-version parameter to the extcap command line. This stated that the command line parameter "--extcap-version=2.9” causes a problem with usbpcap.
The documentation states that in Wireshark 2.9 the command line parameter “--extcap-version x.x” has been added. Note the lack of equal sign. Looking at the code this was originally so, until change 26772 [Ref3] where the equal sign was added due to a problem with some variations of getopt_long(). 

Doesn’t this mean that all other command line parameters with values are to be generated with equal sign?

If so this could require changes across the board, changes to documentation (docbook, man page) in the least.

Ref1: https://code.wireshark.org/review/#/c/28690/
Ref2: https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14982
Ref3: https://code.wireshark.org/review/#/c/26772/

Thanks,
Jaap