Wireshark-dev: Re: [Wireshark-dev] Lua update?
From: Alexis La Goutte <[email protected]>
Date: Thu, 12 Jul 2018 21:08:14 +0200


On Thu, Jul 12, 2018 at 8:48 PM Pascal Quantin <[email protected]> wrote:


Le jeu. 12 juil. 2018 à 20:44, Pascal Quantin <[email protected]> a écrit :
Hi Chris,

Le jeu. 12 juil. 2018 à 20:30, Maynard, Chris <[email protected]> a écrit :

Is there any particular reason why Wireshark for Windows still ships with Lua 5.2.4?  An upgrade to 5.3+ would be a welcome one.

Thanks.


Can our current code run fine with Lua 5.3/5.4? Based on previous discussions in -dev I thought it was not the case but maybe I'm wrong (I'm not a Lua user myself and this is based on exchanges from a few years ago).
If it is safe, I will happily update the package.

And would the existing scripts be compatible with Lua 5.3 or 5.4?
There is also a issue with a lib using by Wireshark (luabit if remember)

Cheers


Pascal.


___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    https://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
             mailto:[email protected]?subject=unsubscribe