Wireshark-dev: Re: [Wireshark-dev] When to drop Qt 4 support and require Qt 5?
From: Guy Harris <[email protected]>
Date: Thu, 25 Jan 2018 15:13:42 -0800
On Jan 25, 2018, at 2:15 PM, Roland Knall <[email protected]> wrote:

> But as far as versions go, it was agreed at SFEU17, that all dependencies for 2.4 must be set for 2.6 as well. 3.0 is when we cut off, and for now, I would keep it that way.
> 
> 2.6 should be the final LTS for gtk and qt4.8

Speaking of dropping support for older Qt versions and the OSes that require them:

Qt 5.3.2 is the last version that supports macOS 10.6/Snow Leopard; do we want to drop support for Snow Leopard at some point?

This page:

	http://doc.qt.io/qt-5/supported-platforms.html

claims that 10.11 through 10.13 are the versions *officially* supported by Qt 5.10; I don't know whether that just means "we don't test with 10.7 through 10.10" or if it means "we know that this doesn't work with 10.7 through 10.10" (5.4 definitely does not work with 10.6/Snow Leopard).  I don't know how far you have to go back to continue to support 10.7/Lion.