Wireshark-dev: Re: [Wireshark-dev] Where to put my wiretap plugin?
From: João Valverde <[email protected]>
Date: Fri, 19 Jan 2018 03:46:56 +0000

On 18-01-2018 16:46, Jaap Keuter wrote:
Hi,

As a follow up I’ve been trying to get the wiretap plugin going. It’s sources are setup in the proper location and when build it’s reported in the About Wireshark dialog and tshark -G plugins output as a ‘file type’ plugin. So far so good.
However there’s a difference between the autotools vs. cmake build. Even though that both builds show the plugin loaded in the About Wireshark dialog the build with autotools refuses to recognise the file type, while the cmake build does accept it. Some instrumentation shows that in the autotools build the wtap_register_<file type> is never called, while in the cmake build it is. How can it show up in the plugin list, while not being registered? What influence does the build environment have here?
If the plugin is loaded I don't see how the build system could have any 
influence either.
Thanks,
Jaap

On 16 Jan 2018, at 15:32, Jaap Keuter <[email protected]> wrote:

Hi João,

Thanks, I’ll reconfigure my work space accordingly and see what I can come up with.
Once it’s ready I should be able to push a nice example.

Thanks,
Jaap


On 16 Jan 2018, at 15:27, João Valverde <[email protected]> wrote:

Hi Jaap,

Yes, that's correct, it should go in plugins/wiretap.

Let me know if you have any issues.

On 16-01-2018 14:25, Jaap Keuter wrote:
Hi,
With the recent change of dissector plugin location (/plugins => /plugins/epan) I assume that my wiretap plugin has to go in /plugins/wiretap ?
Thanks,
Jaap
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    https://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
              mailto:[email protected]?subject=unsubscribe