Wireshark-dev: Re: [Wireshark-dev] 2.5.0 release on January 16
From: Anders Broman <[email protected]>
Date: Thu, 18 Jan 2018 23:13:47 +0100
Ok,
Probably need a complete rebuild then.
Thanks 
Anders

Den 18 jan. 2018 9:09 em skrev "Pascal Quantin" <[email protected]>:
Hi Anders,

2018-01-18 18:23 GMT+01:00 Anders Broman <[email protected]>:


Den 17 jan. 2018 8:37 em skrev "Stig Bjørlykke" <[email protected]>:
On Wed, Jan 17, 2018 at 2:05 AM, Gerald Combs <[email protected]> wrote:
> On 1/13/18 4:16 AM, Stig Bjørlykke wrote:
>> - Qt: Missing string translations after source code was moved to
>> utils/models/manager/widgets subdirectories
>
> Do you know what's missing? This shouldn't be too hard to fix.

I haven't investigated this, but I'm thinking that the generation of
the *.ts files should also include the source subdirectories.  The
translations was lost just after the move to separate directories.


>> - ByteView: Hovering bytes does not highlight the field as it used to do
>> - ByteView: Vertical white and horisontal black lines issues
>> - ByteView: Color issue when clicking a byte multiple times
>
> The 2.4 byte view didn't distinguish between hovered and a locked bytes.
> I initially tried to do so by drawing an overline+undlerline over hovered bytes
> and coloring locked bytes. Change 25348 draws a full outline instead of an
> overline+undlerline.

The change makes this issues better.  I'm still not sure about the
"blue text on yellow background" when locked, this does not look so
good with the macOS colour schemes.  Maybe this could be changed to a
red thicker outline?  Or maybe use our "marked packet" colours?  Or a
combination.

I never understood the white vertical lines, but now it seems like
it's a bug when drawing the background colour.  Have a look at the
attached picture.

When locking a byte the first time all bytes within a protocol has
grey background colour but this grey background colour is not added on
subsequent locks within the same protocol byte range.

And selecting a byte does not expand the corresponding tree item as it
does in 2.4.


--
Stig Bjørlykke


Hi, 
Are anyone else seeing a problem with the expert dialog being empty?

I just tried with the current top of tree on my Linux machine using Qt 5.9.1 and it works fine.

BR,
Pascal.

___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    https://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
             mailto:[email protected]wireshark.org?subject=unsubscribe