Wireshark-dev: Re: [Wireshark-dev] GTK version broken in master?
From: Anders Broman <[email protected]>
Date: Tue, 19 Dec 2017 09:12:10 +0000

 

 

From: Wireshark-dev [mailto:[email protected]] On Behalf Of Michael Mann via Wireshark-dev
Sent: den 18 december 2017 22:54
To: [email protected]
Cc: Michael Mann <[email protected]>
Subject: Re: [Wireshark-dev] GTK version broken in master?

 

>Well it was nice of you to break it ;)

 

I try my best 😉

It did not sow up in the Qt version.

 

> 

>I had a heck of time hunting this down.  Part of the problem was that I had (capture) preferences changed (capture.real_time_update) and I'm not sure how they were >changed.   Not sure if the bug created before the fix had something to do with it, but I chased some red herrings [1] due to corrupted preferences that must have gotten saved >doing unrelated work.

> 

>Michael

> 

> 

 

I have another problem; in the GTK version open Analysis-> enabled protocols and then close the window.

(lt-wireshark-gtk:3737): Gtk-WARNING **: /build/gtk+3.0-3sSotQ/gtk+3.0-3.10.8/./gtk/gtkwidget.c:7923: widget not within a GtkWindow

Segmentation fault (core dumped)

 

Regards

Anders

 

 

-----Original Message-----
From: Anders Broman <
[email protected]>
To: wireshark-dev <[email protected]>
Sent: Mon, Dec 18, 2017 10:17 am
Subject: [Wireshark-dev] GTK version broken in master?

Hi,

I think the GTK version is broken in master – if anyone cares 😊

 

Starting a capture a protocol hierarchy table pops up and the application cannot be closed again.

 

Regards

Anders

___________________________________________________________________________ Sent via: Wireshark-dev mailing list <wireshark-[email protected]> Archives: https://www.wireshark.org/lists/wireshark-dev Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev mailto:[email protected]?subject=unsubscribe