Wireshark-dev: Re: [Wireshark-dev] Remove our bundled crypto library (in favor of Libgcrypt)?
From: Erik de Jong <[email protected]>
Date: Sun, 5 Feb 2017 16:40:07 +0100
I'm working on something where I have to spread ifdef's around the place to work around gcrypt being optional. If there are no platform related issues then by all means make it mandatory.

On Sun, Feb 5, 2017 at 4:21 PM, Peter Wu <[email protected]> wrote:
Hey,

Recently I discovered that wsutil actually contains a lot of
cryptographic functionalities (AES, SHA-1, DES, etc.). This duplicates
Libgcrypt functionality.

At the moment Libgcrypt is optional and used to provide decryption
functionality for SSL/TLS/DTLS, IPsec DVBCI, 802.15.4, SNMP, Zigbee and
more.  What do you think about nuking the bundled crypto routines in
wsutil and use Libgcrypt instead?

The easiest option would be making Libgcrypt mandatory, otherwise we
would have to add ifdef's everywhere (or create a compatibility layer
that disables crypto when Libgcrypt is unavailable).
--
Kind regards,
Peter Wu
https://lekensteyn.nl
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    https://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-[email protected]wireshark.org?subject=unsubscribe