Wireshark-dev: Re: [Wireshark-dev] Recommended QT version to build Wireshark Master ?
From: Graham Bloice <[email protected]>
Date: Mon, 12 Sep 2016 23:06:07 +0100


On 12 September 2016 at 20:22, Bill Meier <[email protected]> wrote:
On 9/12/2016 3:11 PM, Bill Meier wrote:
I'm finally getting around to building Wireshark (Windows 7 32 bit) again.

What version of QT should be used ?

WSDG sec 2.2.4  doesn't really say (although shows 5.5 in the example).
WSDG sec 2.2.10 (which I just happened to see) says 5.6.1
The Master buildbot seems to be using 5.3

Also: wdsg sec 2.2.4 implies that the "OpenGL" version should be used.
Is this correct ?


Update: I now see that master is actually using QT 5.6 so I'll use that version. (I was wrongly looking at a Wireshark 2.2 builder).

Still not sure about Open-GL vs not Open-GL ?


As per the WSDG, Sect 2.2.10, 5.6.1 is recommended, although there is a -1 build out now from Qt.

I don't think you get the choice of non Open GL for 5.6 onwards.

The docs could be cleaned up a bit here, they should list the recommended Qt versions for each release and all the examples should be consistent.

Windows is actually a bit further forwards here in the Qt version used, because of no in-built distribution inertia.

--
Graham Bloice