Wireshark-dev: Re: [Wireshark-dev] Problems compiling wireshark 2.0.5 on Amazon Linux AMI
From: Guy Harris <[email protected]>
Date: Wed, 31 Aug 2016 11:04:14 -0700
On Aug 31, 2016, at 6:06 AM, Zach Moshe <[email protected]> wrote:

> I'm trying to compile wireshark 2.0.5 from sources on an Amazon Linux machine (AMI release 2015.03).
> I run configure with --disable-wireshark as I only need tshark.
> 
> After installing all requirements, compilation goes fine, but I get this on linking stage: 
> 
> Making all in .
> make[2]: Entering directory `/home/ec2-user/wireshark-2.0.5'
>   CCLD     tshark
> /usr/bin/ld: ui/cli/libcliui.a(libcliui_a-tap-comparestat.o): undefined reference to symbol '[email protected]@GLIBC_2.2.5'
> /usr/bin/ld: note: '[email protected]@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
> /lib64/libm.so.6: could not read symbols: Invalid operation

	...

> config.log is attached.

Could you also send the top-level Makefile?  From the configure output, it looks as if it should already be linking with libm, but it's apparently not doing so.