Wireshark-dev: Re: [Wireshark-dev] MSVC 2015 (VC14) notes/issue
From: Pascal Quantin <[email protected]>
Date: Mon, 31 Aug 2015 18:18:26 +0200


2015-08-31 18:10 GMT+02:00 Bill Meier <[email protected]>:
On 8/31/2015 4:24 AM, Pascal Quantin wrote:
 > May be directly move to GeoIP 2 ?
 > https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=10658
 >
 >
 >
 > I think the code is available from here:
 >
 > https://github.com/maxmind/libmaxminddb

Hi all,

I propose to do it in 2 steps as changing the library is more work than
upgrading the current one:
- first recompile version 1.6.6 and see if it solves the build issue
with MSVC2015 (I'm gonna cross compile it as I have the environment). I
will send an email once it is ready for testing (as I did for Lua).
- then eventually change the library (and keep backward compatibility
with the older one?).



According to https://github.com/maxmind/libmaxminddb, the license is Apache V2.


From: http://www.apache.org/licenses/GPL-compatibility.html

"Despite our best efforts, the FSF has never considered the Apache License to be compatible with GPL version 2, citing the patent termination and indemnification provisions as restrictions not present in the older GPL license. The Apache Software Foundation believes that you should always try to obey the constraints expressed by the copyright holder when redistributing their work."

So: It would seem that doing an upgrade to use libmaxminddb may not be OK.

(I did the license chack after noticing that the Fedora22 repository does not contain libmaxminddb).


Interesting... You should definitely put this in bug 10658.

Pascal.