Wireshark-dev: Re: [Wireshark-dev] Windows petri-dish unhappy
From: Hadriel Kaplan <[email protected]>
Date: Fri, 24 Jul 2015 11:36:51 -0400
Oh right, looking at successful builds, it looks like git basically
*always* fails once.  Weird.

-hadriel


On Fri, Jul 24, 2015 at 11:28 AM, Graham Bloice
<[email protected]> wrote:
> On 24 July 2015 at 16:18, Hadriel Kaplan <[email protected]> wrote:
>>
>> Howdy,
>> The Windows petri-dish keeps failing in the middle of git fetching.
>> It's failed 4 times in a row now, including for change 9769 which is
>> basically just master.
>>
>> Looking at stackoverflow responses to similar issues, it seems some
>> people have better luck using SSH instead of HTTPS (the Windows
>> petri-dish is using https).  Also, some folks recommend wiping out the
>> repo locally and doing a git clone but with the "--depth" option set
>> low.  There're also some comments that increasing the http.postBuffer
>> value in git config might help.
>>
>
> I think the actual issue causing the builds to fail is the CMake
> configuration pass isn't finding 7zip (7za.exe) and falls back to
> downloading the executable from anonsvn but fails to do so.
>
> I changed the search for 7zip yesterday, it would appear that the PD
> buildbot doesn't have 7-zip installed in the expected places.
>
> I'm looking at this now.
>
>
> --
> Graham Bloice
>
> ___________________________________________________________________________
> Sent via:    Wireshark-dev mailing list <[email protected]>
> Archives:    https://www.wireshark.org/lists/wireshark-dev
> Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
>              mailto:[email protected]?subject=unsubscribe