Wireshark-dev: [Wireshark-dev] Dissector plugin not working with wireshark 1.12.3
From: yannick omnes <[email protected]>
Date: Tue, 17 Feb 2015 10:08:14 +0100
Hi list,

I've recently updated my Wireshark to 1.12.3. I created a plugin that worked fine with previous versions but now I'm facing some problems.
The plugins still compile and is correctly loaded by wireshark on Windows

On my ubuntu 14.04, it is not loaded anymore. The problem seems to come from the register fonction. If there is only one element in the hf_register_info array, the plugin is being correctly loaded by Wireshark. But with more than one items, Wireshark crashes.
Does anyone know what's wrong ?

Regards,