Wireshark-dev: [Wireshark-dev] Structures change in versions
From: Eshed Shaham <[email protected]>
Date: Sat, 29 Mar 2014 15:10:35 +0200
Hello,
Unfortunately, this minor change broke my plugin's (pyreshark) interfacing with Wireshark, with a fix requiring either having two versions for the 1.8 branch (I currently provide a single version of the plugin for every minor version (1.8, 1.10) of Wireshark) or adding some ugly hack to determine the version during runtime.

While I can't say it's critical, as I only discovered this change nearly a year after it was introduced, I do see merit in freezing the API in minor versions, to keep plugin versions at a minimum.

I apologise if the above seems accusative, I'm not a native English speaker, so my words might have conveyed the wrong message. My intention was to bring this issue to your attention with the hope that in the future you'll take it into consideration during future development.

Thanks for all your hard work!
Eshed