Wireshark-dev: Re: [Wireshark-dev] 1.11.0 release
From: Joerg Mayer <[email protected]>
Date: Wed, 9 Oct 2013 20:03:05 +0200
On Wed, Oct 09, 2013 at 03:15:41PM +0200, Bálint Réczey wrote:
> According to our CMakeList.txt it will be:
> ...
> project(Wireshark C CXX)
> 
> cmake_minimum_required(VERSION 2.6)
> set(CMAKE_BACKWARDS_COMPATIBILITY 2.6)
> ...

Unless you want to build with Qt5:
http://qt-project.org/doc/qt-5.0/qtdoc/cmake-manual.html
states:
 CMake is a 3rd party tool with its own documentation. The rest of this
 manual details the specifics of how to use Qt 5 with CMake. The minimum
 version required to use Qt5 is CMake 2.8.3, but 2.8.9 is recommended."

So people who want a Qt5 version will not be happy with an old cmake.
On the other hand: The setup script for macos has an option to add cmake
to the list of tools/libs to download and build, so it isn't a really
unusual situation and it isn't hard to handle either.

Ciao
    Jörg
-- 
Joerg Mayer                                           <[email protected]>
We are stuck with technology when what we really want is just stuff that
works. Some say that should read Microsoft instead of technology.