Wireshark-dev: Re: [Wireshark-dev] Wireshark-commits: [Wireshark-commits] rev 44161: /trunk/epa
Date: Tue, 31 Jul 2012 15:35:19 -0400 (EDT)
I guess where I (and the .pl script) got tripped up was the fact that there were separate protocols registered and they gave the impression they were unique and not just "one big protocol" broken up over several files.   The script just generates the "questionable" filters, I was using "human judgement" to determine if the filters actually needed to be changed.   Looking through the filter names, renaming to gmr1_ccch.* seems to make more sense then renaming the protocol to gmr1_rr.  It was all a judgement call by me, but I'm happy to admit I'm wrong to someone who knows the specific protocols better.  The overall goal is just consistency in display filter names (bug 2794), but it can get complicated for the .pl script when protocols are broken up over multiple files.
 
-----Original Message-----
From: Pascal Quantin <[email protected]>
To: Developer support list for Wireshark <[email protected]>
Sent: Tue, Jul 31, 2012 3:07 pm
Subject: [Wireshark-dev] Wireshark-commits: [Wireshark-commits] rev 44161: /trunk/epan/dissectors/ /trunk/epan/dissectors/: packet-gmr1_bcch.c packet-gmr1_common.c packet-gmr1_rr.c


http://anonsvn.wireshark.org/viewvc/viewvc.cgi?view=rev&revision=44161

User: mmann
Date: 2012/07/31 10:19 AM

Log:
 update GMR-1 protocols display filers

Directory: /trunk/epan/dissectors/
  Changes    Path                    Action
  +67 -67    packet-gmr1_bcch.c      Modified
  +14 -14    packet-gmr1_common.c    Modified
  +100 -100  packet-gmr1_rr.c        Modified


Hi Michael,

What is the rationale for this change exactly? So as to please the check*.pl scripts?
For me it made sense to split big protocols in various files while still having a common root for filters.
Moreover the rename from gmr1.rr.* to gmr1_ccch.* does not seem valid to me as the corresponding fields can be received either on CCCH or DCCH channels (the protocol name gmr1_ccch does not seem well chosen and might be named gmr1_rr instead).

Regards,
Pascal.
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:[email protected]?subject=unsubscribe