Wireshark-dev: Re: [Wireshark-dev] LNK2005 and LNK1169 errors - statistics implementation
From: Corentin <[email protected]>
Date: Tue, 29 May 2012 12:20:41 +0200
Hello Jakub,

Your answer is totally right. I had one "version" variable there, I renamed it "subnet_version" and it perfectly compiles.

Thank you very much,

Corentin.



Le 29 mai 2012 à 11:27, Jakub Zawadzki <[email protected]> a écrit :

> Hi,
> 
> On Tue, May 29, 2012 at 11:14:23AM +0200, Corentin wrote:
>> Here are my error messages :
>> plugin.obj : error LNK2005: _version already defined in packet-subnet.obj
>> Creating library subnet.lib and objet subnet.exp subnet.dll : fatal error
>> LNK1169: one or more mutliply defined symbols found NMAKE : fatal error
>> U1077 : <path to="" link.exe=""> : return code '0x491' NMAKE : fatal error
>> U1077 : <path to="" nmake.exe=""> : return code '0x2' Stop.
>> 
>> If you have any idea, or suggestion, that could help getting rid of this
>> problem, this would greatly appreciated !
> 
> Do you have some variable called 'version' in packet-subnet.c?
> If yes rename it to some subnet_version. hth.
> 
> Cheers,
> Kuba.
> ___________________________________________________________________________
> Sent via:    Wireshark-dev mailing list <[email protected]>
> Archives:    http://www.wireshark.org/lists/wireshark-dev
> Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
>             mailto:[email protected]?subject=unsubscribe