Wireshark-dev: Re: [Wireshark-dev] [Wireshark-commits] rev 42676: /trunk/epan/ /trunk/epan/: pr
From: Jakub Zawadzki <[email protected]>
Date: Mon, 28 May 2012 20:56:24 +0200
On Mon, May 28, 2012 at 12:53:23PM -0400, Maynard, Chris wrote:
> Was it the intention to call the function, protoo_strlcpy(), or is that a typo and it should be renamed to proto_strlcpy()?

I did it on purpose, to make commit looks nicer:
  (int)g_strlcpy
  protoo_strlcpy

Still it's workaround. Ultimately I hope to remove this function.
I just need to find some motivation and guard all g_strlcpy(), g_snprintf() with offset_[er] < size.