Wireshark-dev: Re: [Wireshark-dev] SVN HEAD not building
From: Anders Broman <[email protected]>
Date: Sun, 27 May 2012 12:32:12 +0200
Akos Vandra skrev 2012-05-27 11:30:
Yep, that helped, thanks!

However when I tried to take a sneak peek at how the qt inteface looks
like, I found that the build fails because of a missing file?
I know it is experimental only, but it should build, right?
Are you building from a tarball?
http://anonsvn.wireshark.org/viewvc/trunk/ui/qt/main_window.h?revision=41275&view=markup
You can down load the file from the link above perhaps it's missing from the tarball?
Regards
Anders
Making all in ui/qt
make[2]: Entering directory `/home/akos/projects/c/wireshark/wireshark/ui/qt'
g++ -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../wiretap    -DINET6
-DG_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES -DQT_GUI_LIB
-D_FORTIFY_SOURCE=2 -D_U_="__attribute__((unused))"
-I/home/akos/projects/c/wireshark/bin/include -I/usr/local/include
-I/home/akos/projects/c/wireshark/bin/include/pcap
'-DPLUGIN_DIR="/home/akos/projects/c/wireshark/bin/lib/wireshark/plugins/1.7.2"'
  -g -O2 -Wall -W -Wextra -Wendif-labels -Wpointer-arith -Warray-bounds
-Wcast-align -Wformat-security -DQT_SHARED -I/usr/include/qt4
-I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui   -pthread
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -MT
main_window.o -MD -MP -MF .deps/main_window.Tpo -c -o main_window.o
main_window.cpp
main_window.cpp:25: fatal error: ui_main_window.h: No such file or directory
compilation terminated.
make[2]: *** [main_window.o] Error 1
make[2]: Leaving directory `/home/akos/projects/c/wireshark/wireshark/ui/qt'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/akos/projects/c/wireshark/wireshark'
make: *** [all] Error 2

Regards,
   Ákos Vandra


On 27 May 2012 08:40, Guy Harris<[email protected]>  wrote:
On May 26, 2012, at 7:30 PM, Bill Meier wrote:

I did (had to do ?) a complete rm config.cache, ./autogen.sh and ./configure sequence before doing  make to get rid of the error.
I had a similar problem, but I didn't have to do "rm config.cache" - re-running autogen.sh and configure was sufficient.

(I was too lazy to determine the actual reason for the error).
I think the actual reason for the error is "automake does not generate Makefile.in files that have a sufficient number of dependencies to force a rebuild of everything that needs to be rebuilt if something included by a Makefile.am file is changed". :-)  Perhaps, due to limitations of (GNU) make, "does not" should be replaced by "cannot".
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list<[email protected]>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:[email protected]?subject=unsubscribe
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list<[email protected]>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
              mailto:[email protected]?subject=unsubscribe