Wireshark-dev: [Wireshark-dev] including GPLv3 autoconf macro in Wireshark
From: Jeff Morriss <[email protected]>
Date: Fri, 18 May 2012 14:55:06 -0400
Hi folks,

I found out recently that Wireshark needs the Z_BLOCK macro which is only in zlib 1.2.0.5 and later. Rather than checking explicitly for the version (which seemed like it would be a pain) I thought I'd check for the macro.
A quick search for AC_CHECK_DEFINE found me something in the Autoconf 
Archive[1] but (just before I checked it in, I discovered that) the 
current version[2] is GPLv3.
[1] https://www.gnu.org/software/autoconf-archive/
[2] http://git.savannah.gnu.org/gitweb/?p=autoconf-archive.git;a=blob_plain;f=m4/ax_check_define.m4
I've never done much with license compatibilities, so I have to ask: can 
I add this macro to Wireshark's aclocal-fallback?  Or do I have to find 
another solution?
Thanks,
-Jeff