Wireshark-dev: [Wireshark-dev] Bug found
From: "Steven W. Stoner" <[email protected]>
Date: Fri, 24 Feb 2012 14:22:30 -0000

Hello all,

 

I just installed your version 1.7.0 SVN Rev 39768 from /trunk and started the application.  There is an error you have in initial window placement, which is difficult to resolve in Windows 7.  The problem is that on a two monitor system, you appear to always position the window at position 0,0.   On a single window system this is no problem, but on a dual monitor system, when the leftmost monitor has a smaller resolution than the right monitor, and when it does not have the same top position as the right monitor, one is unable to see or move the window and the title bar and in my case the menu bar and a good portion, down to the interface list, is not visible. 

 

One would say to hit Alt+Space to open then system menu and select move, but that does not work on windows 7.  Also a right click on the icon in the taskbar would bring up the system menu.  That does not work in windows 7 either.  I finally searched and found that Shit + right click the icon in the task bar brought up the system menu so I could select move and reposition the window so it was visible.

 

I would suggest letting the windows system itself handle the initial placement of the window.  This occurs each time it is opened also.  It does not remember the last position it was in when used, so this must be done each time the window is opened.  If you need any help, send me a code snippet on the original window placement, including the resource for the object.  I hope this is helpful and if you need any more assistance with this, or would like a new version tested to see if fixed, then feel free to contact me.  You have my contact details here.

 

 

 

Best wishes,

 

Steven W. Stoner

 

 

Landline: +44 (0)1273 960408

Mobile..: +44 (0)7588 877556