Wireshark-dev: Re: [Wireshark-dev] configure: error: GTK+ 2.12 or
From: Anders Broman <[email protected]>
Date: Tue, 31 Jan 2012 14:36:39 +0100
Hi,
Not that I know a lot about config but,
>usr/lib/gcc/i686-pc-linux-gnu/4.5.3/../../../../lib/libcairo.so: undefined reference to `qt_draw_glyphs(QPainter*, unsigned int const*, QPointF const*, int)'
I would mark the recompiled cairo as the prime suspect...
Regards
Anders 

-----Original Message-----
From: [email protected] [mailto:[email protected]] On Behalf Of Toralf Förster
Sent: den 30 januari 2012 18:44
To: [email protected]
Subject: [Wireshark-dev] configure: error: GTK+ 2.12 or

For the current SVN trunk I run into this :

checking for GTK+ - version >= 2.12.0 and < 3.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: GTK+ 2.12 or later isn't available, so Wireshark can't be compiled


The installed version is x11-libs/gtk+-2.24.8-r1 at an Gentoo Linxu system.
Before that I updated KDE to 4.8, qt to 4.8 and recompiled cairo lib - nothing else IIRC.

I already run "./autogen.sh" and "export CC="ccache gcc"; ./configure" 

:-(

--
MfG/Sincerely
Toralf Förster
pgp finger print: 7B1A 07F4 EC82 0F90 D4C2 8936 872A E508 7DB6 9DA3