Wireshark-dev: Re: [Wireshark-dev] Increase minimum GLib and GTK+ versions?
From: Stephen Fisher <[email protected]>
Date: Tue, 12 Jul 2011 09:41:43 -0600
On Wed, Jul 06, 2011 at 10:48:21AM -0700, Gerald Combs wrote:

> Is there any reason we shouldn't make GLib 2.14.0 and GTK+ 2.12.0 the 
> minimum required versions to build Wireshark? This would let us get 
> rid of a lot of instances of "#if GLIB_CHECK_VERSION" and #if 
> GTK_CHECK_VERSION". Both were released almost four years ago. Each of 
> the GLib and GTK+ releases from 2005 to 2007 are listed below:

It's fine by me like usual :).  The main reason that comes to mind is I 
believe Solaris ships with version 2.4 still according to something I 
read.