Wireshark-dev: [Wireshark-dev] Increase minimum GLib and GTK+ versions?
From: Gerald Combs <[email protected]>
Date: Wed, 06 Jul 2011 10:48:21 -0700
Is there any reason we shouldn't make GLib 2.14.0 and GTK+ 2.12.0 the
minimum required versions to build Wireshark? This would let us get rid
of a lot of instances of "#if GLIB_CHECK_VERSION" and #if
GTK_CHECK_VERSION". Both were released almost four years ago. Each of
the GLib and GTK+ releases from 2005 to 2007 are listed below:

GLib 2.8.0     Aug 13, 2005
GLib 2.10.0    Feb 24, 2006
GLib 2.12.0    Jul  2, 2006
GLib 2.14.0    Aug  3, 2007

GTK+ 2.8.0     Aug 13, 2005
GTK+ 2.10.0    Jul  3, 2006
GTK+ 2.12.0    Sep 14, 2007