Wireshark-dev: [Wireshark-dev] NMAKE : fatal error U1077: 'sed' : return code '0x1'
From: Jason Williams <[email protected]>
Date: Fri, 3 Dec 2010 15:50:55 -0600
I am trying to compile Wireshark on Windows and I am running into the following error:

NMAKE : fatal error U1077: 'sed' : return code '0x1'

I have followed all of the steps in the developer guide for setting up my environment and I haven't been able to figure out what I am missing.  I searched through the archives and found one instance of a similar error but didn't see a resolution.  Here is what I get after running nmake command:

Wireshark is ready to build.
        sed -e s/@[email protected]/1.4.2/  -e "s/@[email protected]/#define HAVE_C_ARES 1/"
-e "s/@[email protected]//"  -e "s/@[email protected]//"  -e "s/@[email protected]/#define HAVE_MI
T_KERBEROS 1/"  -e "s/@[email protected]//"  -e "s/@[email protected]/#define HAVE_LIBZ 1/"
 -e "s/@[email protected]/#define HAVE_GZCLEARERR 1/"  -e "s/@[email protected]/#defi
ne HAVE_LIBPCAP 1/"  -e "s/@[email protected]/#define HAVE_PCAP_FINDALLDEVS
 1/"  -e "s/@[email protected]/#define HAVE_PCAP_DATALINK_NAME_TO_
VAL 1/"  -e "s/@[email protected]/#define HAVE_PCAP_DATALINK_VAL_T
O_NAME 1/"  -e "s/@[email protected]/#define HAVE_PCAP_DATA
LINK_VAL_TO_DESCRIPTION 1/"  -e "s/@[email protected]//"  -e "s/@[email protected]
/#define HAVE_REMOTE 1/"  -e "s/@[email protected]/#define HAVE_PCAP_REMOTE 1/"
 -e "s/@[email protected]/#define HAVE_PCAP_OPEN 1/"  -e "s/@HAVE_PCAP_LIST_DATALI
[email protected]/#define HAVE_PCAP_LIST_DATALINKS 1/"  -e "s/@[email protected]/#def
ine HAVE_PCAP_FREE_DATALINKS 1/"  -e "s/@[email protected]/#define HAVE_PC
AP_SET_DATALINK 1/"  -e "s/@[email protected]/#define HAVE_PCAP_SETSAMPLING
 1/"  -e "s/@[email protected]/#define HAVE_LIBWIRESHARKDLL 1/"  -e "s/@HAVE
[email protected]/#define HAVE_LIBGNUTLS 1/"  -e "s/@[email protected]/#define HAVE_LIBG
CRYPT 1/"  -e "s/@[email protected]/#define HAVE_LUA 1/"  -e "s/@[email protected]/#define H
AVE_LUA_5_1 1/"  -e "s/@[email protected]//"  -e "s/@[email protected]/#define HAVE_AIRPC
AP 1/"  -e "s/@[email protected]/#define HAVE_AIRPDCAP 1/"  -e "s/@HAVE_LIBPORTAUDI
[email protected]/#define HAVE_LIBPORTAUDIO 1/"  -e "s/@[email protected]//"  -e "s/@[email protected]/#
define HAVE_LIBSMI 1/"  -e "s/@[email protected]/#define HAVE_GEOIP 1/"  -e "s/@HAVE_N
[email protected]/#define NEW_PACKET_LIST 1/"  -e "s/@[email protected]/#define INET6 1/"  -e
 "s/@[email protected]/#define HAVE_NTDDNDIS_H 1/"  < config.h.win32 > config.h
The system cannot find the file specified.
NMAKE : fatal error U1077: 'sed' : return code '0x1'
Stop.

Here is the output from verify_tools:
Checking for required applications:
        cl: /c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/cl
        link: /c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/link
        nmake: /c/Program Files/Microsoft Visual Studio 9.0/VC/BIN/nmake
        mt: /c/Program Files/Microsoft SDKs/Windows/v6.0A/bin/mt
        bash: /usr/bin/bash
        bison: /usr/bin/bison
        flex: /usr/bin/flex
        env: /usr/bin/env
        grep: /usr/bin/grep
        /usr/bin/find: /usr/bin/find
        perl: /usr/bin/perl
        C:\Python24\python.exe: /c/Python24/python.exe
        sed: /usr/bin/sed
        unzip: /usr/bin/unzip
        wget: /usr/bin/wget

And here is my current Path:
PATH=C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE;C:\Program Files\M
icrosoft Visual Studio 9.0\VC\BIN;C:\Program Files\Microsoft Visual Studio 9.0\C
ommon7\Tools;C:\WINNT\Microsoft.NET\Framework\v3.5;C:\WINNT\Microsoft.NET\Framew
ork\v2.0.50727;C:\Program Files\Microsoft Visual Studio 9.0\VC\VCPackages;C:\Pro
gram Files\Microsoft SDKs\Windows\v6.0A\bin;C:\Program Files\Windows Resource Ki
ts\Tools\;C:\Tcl\bin;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Progra
m Files\IBM\Director\bin;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;e:
\cygwin\bin;C:\Program Files\ssh communications security\ssh Secure Shell