Wireshark-dev: Re: [Wireshark-dev] MacOS/X builds
From: Guy Harris <[email protected]>
Date: Wed, 7 Jul 2010 11:21:22 -0700
On Jul 6, 2010, at 6:26 PM, Ian Schorr wrote:

> r33458 Intel 64-bit now works for me.  A couple of recent builds,
> including 33452, did not (32-bit did and still does).
> 
> r33458 PPC crashes for me, with:
> 
> 2010-07-07 11:31:06.785 defaults[24422:10b]
> The domain/default pair of (kCFPreferencesAnyApplication,
> AppleAquaColorVariant) does not exist
> 2010-07-07 11:31:06.814 defaults[24423:10b]
> The domain/default pair of (kCFPreferencesAnyApplication,
> AppleHighlightColor) does not exist
> dyld: Library not loaded: /usr/X11/lib/libpng12.0.dylib
>  Referenced from:
> /Applications/Wireshark.app/Contents/Resources/bin/wireshark-bin
>  Reason: Incompatible library version: wireshark-bin requires version
> 42.0.0 or later, but libpng12.0.dylib provides version 36.0.0

Did the build before 33458 work on PPC?  I suspect not - that's an issue of the libraries with which wireshark-bin is built, and wireshark-bin (i.e., the actual Wireshark binary, rather than the wrapper for it) has never been built with an SDK.  That problem has shown up before.  (The fix for that is to build everything with an SDK, but that's more work.)