Wireshark-dev: Re: [Wireshark-dev] dissector plugin help
From: Brian Oleksa <[email protected]>
Date: Thu, 26 Mar 2009 16:25:18 -0400
Olivier (wsgd)

I fixed the problem in the code that you found. Thanks again for finding this.
I tested it on the development machine and it worked great.!!

I then took the created helen.dll file and dropped it on a deploy machine that is running the same version of wireshark that I developed against only to find that it "Couldn't load module", The specified module could not be found.
Any suggestions or thoughts on this one..?

Thanks again for all your help.

Brian



wsgd wrote:
Hello,

Into proto_reg_handoff_helen,
 you try to fopen("/root/ports", "r"),
 which certainly fails on windows,
 so you call exit(1).



Olivier

Brian Oleksa a écrit :
Wiresharkers

I have followed these instructions: (I used both of these as one was more clear than the other on certain tasks).
http://www.codeproject.com/KB/IP/custom_dissector.aspx
http://www.wireshark.org/docs/wsdg_html_chunked/ChSetupWin32.html

I am using:

MSVC_VARIANT=MSVC2008EE

I then verify_tools, install libraries (nmake -f Makefile.nmake setup), distclean and build wireshark with *NO *problems.
I then test wireshark and it does indeed start up with *NO *problems.

I then create my wireshark dissector code, make files etc.*
(NOTE: This runs on Linux FC-9 with NO problems. If I take the attached helen.zip file go to my linux box, do a make install and put the helen.so file in the plugin directory everything works fine.)
*


I drop my code in place. C:\wireshark\plugins\helen
The name of my wireshark dissector is called helen.

From the C:\wireshark\plugins\helen directory I do the following:
nmake -f Makefile.nmake distclean
nmake -f Makefile.nmake all

I have NO errors and it does indeed create a *helen.dll* file. (Which I believe is what I want).
I drop this helen.dll file in the following directory:
C:\wireshark\wireshark-gtk2\plugins\1.1.4HELEN-DISSECTOR

I start up wireshark (by invoking wireshark.exe) the splash screen appears for a second than disappears. So it never start up.
It does not provide me with a error message.

I tried the following work around (click on link below) but had NO luck.
http://www.wireshark.org/lists/wireshark-dev/200902/msg00013.html

So at this point...I am stuck.

Attached is all my code (helen.zip). Again, this same code works on my fedora core 9 box.
Any help is greatly appreciated.

Thank you

Brian Oleksa
Software Developer
Dark Corner Software











------------------------------------------------------------------------

___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:[email protected]?subject=unsubscribe