Wireshark-dev: Re: [Wireshark-dev] Trouble integrating plugins on wireshark 1.0.6
From: "CORDUNIANU LAVINIA" <[email protected]>
Date: Wed, 25 Mar 2009 15:33:59 +0100
Title: Trouble integrating plugins on wireshark 1.0.6
 
Hello,

Thanks for the prompt reply.

I actually forgot to mention that the problem appears on Linux (Centos).

Lavinia.


From: [email protected] [mailto:[email protected]] On Behalf Of BARILLY YANN
Sent: Wednesday, March 25, 2009 12:06 PM
To: Developer support list for Wireshark
Subject: Re: [Wireshark-dev] Trouble integrating plugins on wireshark 1.0.6

Hi,
 
If you are working with MSVC2008EE, it might be the problem I have met.
The compilation is not able to make valuable .dll and .dll.manifest
I went back to MSVC2005EE.
 
Look at these mails, if you find an answer :
 
Yann

From: [email protected] [mailto:[email protected]] On Behalf Of CORDUNIANU LAVINIA
Sent: Wednesday, March 25, 2009 10:42 AM
To: [email protected]
Subject: [Wireshark-dev] Trouble integrating plugins on wireshark 1.0.6

Hello all,
I want to implement my plugins with the new wireshark 1.0.6 source. I’ve done this following all the steps suggested on README.plugins.

My problem is that when I start Wireshark I get a series of error messages listed below indicating that some of the plug-in modules could not be loaded. The C-code works fine (no plug in module errors) when compiled and run and also the same plugins work fine with wireshark 1.0.0 .

I would greatly appreciate it if someone could take a look at the below errors:
Couldn't load module
 /usr/local/install//lib/wireshark/plugins/1.0.6/interwac.so: /usr/local/install//lib/wireshark/plugins/1.0.6/interwac.so:  undefined symbol: bitbuf_attach_tvb

Couldn't load module
/usr/local/install//lib/wireshark/plugins/1.0.6/mac.so: /usr/local/install//lib/wireshark/plugins/1.0.6/mac.so: undefined symbol: bitbuf_read_at_offset

Thanks in advance for your help.
Lavinia.