Wireshark-dev: Re: [Wireshark-dev] 'OPENFILENAME_SIZE_VERSION_400' : undeclared identifier
From: Graham Bloice <[email protected]>
Date: Fri, 07 Nov 2008 15:27:54 +0000
CHRIS AKERS wrote:
I'm attempting to build Wireshark again but haven't done this for
about 6 months.  However I'm using exactly the same machine and
software (albeit with an update from SVN etc):


OS:  Windows XP SP2
MSVC:  Microsoft Visual Studio 2008
PSDK:  Microsoft Platform SDK for Windows Server 2003 R2


I've taken the latest update from SVN, re-run nmake setup,
verify_tools and distclean with no problems but when compiling
'file_dlg_win32.c' I get the following error


'file_dlg_win32.c(172) : error C2065: 'OPENFILENAME_SIZE_VERSION_400'
: undeclared identifier'


I can see OPENFILENAME_SIZE_VERSION_400 is defined in CommDlg.h from
the Platform SDK but only if _WIN32_WINNT is greater than or equal to
0x500 which I assume means a version of Windows greater than 4 (which
I am using).


I can also see some remarks regarding this very macro in the
'file_dlg_win32.c' sourcefile but they're not entirely clear to me.
In this file the 'OPENFILENAME_SIZE_VERSION_400' is only used if
_MSC_VER is greater than or equal to 1500 (which according to my
config.nmake is Visual Studio 2008 which, again, is the version I'm
using and the version I have uncommented).


Looking at the the SVN log I can see revisons made to
'file_dlg_win32.c' but nothing that looks as if this part of the
source was affected.  This is coupled with many google searches and
searches on the Wireshark website itself that result in nothing
useful.


Any ideas?  The only thing I can think of is that when I previously
ran the build it somehow wasn't using VS2008 so the _MSC_VER macro was
less than 1500 which meant the 'OPENFILENAME_SIZE_VERSION_400' wasn't
used but I'm absolutely positive I'm using the same versions of all
tools on the box.


I did try manually adding 'OPENFILENAME_SIZE_VERSION_400'  to the
source file (value as 76) and, although this compiled, it's a bit
hacky and Wireshark crashed on startup possibly meaning there are
other problems being hidden here.  I'd like it to build straight from
SVN with only updates to the config and my dissector being the
changes.


Any help greatly appreciated.


  
Have you checked your settings in config.nmake?  There have been quite a few changes in there over the last six months.

-- 
Regards,

Graham Bloice