Wireshark-dev: [Wireshark-dev] Should we also require GLib 2.4 or later?
From: Guy Harris <[email protected]>
Date: Tue, 29 Apr 2008 10:52:16 -0700
GTK+ 2.4 requires GLib 2.4, so if we're building with GTK+, that requires GLib 2.4 or later.
One could, I guess, build everything *but* Wireshark with an earlier 
version of GLib, but requiring 2.2 or later means that, for example, we 
wouldn't have to check for g_ascii_strtoull(), as that first appeared in 
2.2, and requiring 2.4 or later means that we wouldn't have to check for 
G_GINT64_MODIFIER, as that first appeared in 2.4.