Wireshark-dev: Re: [Wireshark-dev] Need help with build problem
From: Donald White <[email protected]>
Date: Tue, 22 Apr 2008 02:11:46 -0700
I found the problem. This time I installed the HTML Help from the VS6.0 disk (1.1). Last time I downloaded HTML Help from MS (1.3). An uninstall and reinstall with the later version fixed everything.
Sorry for the noise.

Don



Anders Broman wrote:
Hi,
See these lines in config.nmake

# Recommended: Use the compressed html help format .chm as the Wireshark
integrated help.
#
# The required htmlhelp.h and htmlhelp.lib should be included in
MSVC_VARIANT > MSVC6.
#
# For MSVC_VARIANT == MSVC6 you will have to download and install the
html help workshop from:
#
#
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/htmlhel
p/html
# /hwMicrosoftHTMLHelpDownloads.asp
#
# Then point HHC_DIR to the html help dir (where hhc.exe resides).
#
# If you don't want the online help (or don't have the tools),
# comment this line out, so that HHC_DIR isn't defined.
#
HHC_DIR=$(PROGRAM_FILES)/HTML Help Workshop

Regards
Anders
-----Original Message-----
From: [email protected]
[mailto:[email protected]] On Behalf Of Donald White
Sent: den 22 april 2008 10:25
To: Developer support list for Wireshark
Subject: [Wireshark-dev] Need help with build problem

After about a year without doing any dissector development, I am again
trying to set up my development environment for Wireshark.  I have tried
to follow the developer guide, but am just missing something.

I am using VS6.0 with SP6 on XP SP2.  I  need to base my development on
Wireshark 1.0 so I created my source tree from /wireshark/trunk-1.0. Maybe I should use /wireshark/releases/wireshark-1.0.0? I initially
tried the /trunk HEAD version but seemed to catch in a bad state and,
besides, I will initially need to distribute plugins for release 1.0..

My current problem is that I get the following error:

Linking wireshark.exe
        link @C:\DOCUME~1\Donald\LOCALS~1\Temp\nma00888.
CVPACK : fatal error CK1022: cannot open program database
e:\wintools\htmlhelp\r elease\htmlhelp.pdb LINK : warning LNK4027:
CVPACK error NMAKE : fatal error U1077: 'link' : return code '0x1'
Stop.

Naturally I have no e: drive and can't find what is generating this
reference.

I have run the makefile for the verify_tools, setup, distclean, clean
and all targets.

Thanks,

Don


_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev
_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev