Wireshark-dev: Re: [Wireshark-dev] Should we support GTK+ 2.0[.x] and 2.2[.x], or just 2.4 and
From: Stephen Fisher <[email protected]>
Date: Mon, 21 Apr 2008 23:40:00 -0600
On Sun, Apr 20, 2008 at 05:35:29PM -0700, Guy Harris wrote:

> Has anybody build Wireshark with a pre-2.4 release recently?  If not, 
> are there enough systems out there with pre-2.4 releases for us to 
> spend any time cleaning up the code to build with them?  If not, 
> should we just get rid of the code to support pre-2.4 releases?

Dropping support for GTK+ < 2.4 would allow us to modernize a *lot* of 
code.

Dates from ftp.gtk.org for older GTK2 versions:

   2.0.9	Nov 20 2002
   2.1.5	Dec 17 2002

   2.2.4	Sep 04 2003
   2.3.6	Mar 09 2004

   2.4.0	Mar 16 2004

I think it is reasonable to expect machines to be upgraded to a GTK+ 
version newer than 4 years old, especially since we're talking about up 
to date versions of Wireshark.  Why upgrade to the latest Wireshark but 
not the latest GTK+?  I say we drop < 2.4 support sooner than later.


Steve