Wireshark-dev: Re: [Wireshark-dev] Should we support GTK+ 2.0[.x] and 2.2[.x], or just 2.4 and
From: Guy Harris <[email protected]>
Date: Mon, 21 Apr 2008 11:09:33 -0700
Luis EG Ontanon wrote:
Should the fact that the "Older Versions" section in
http://www.gtk.org/download-linux.html
does not show anyone bellow 2.4 be taken as a hint on what to do?
A hint on what to do at some point, definitely.  There haven't been any 
bug reports from a system with GTK+ 2.0 in about 1 1/2 years, and two of 
the three bug reports from systems with GTK+ 2.2 are at least 1 1/2 
years old.  The third one is fairly recent, coming from some version of 
Red Hat with a 2.4.x kernel; unfortunately, I don't know of any generic 
way to determine what version of what Linux distribution you're running 
on, so I don't know of any way to say "Red Hat Linux 8.1" in the -v output.
Given that we're not regularly building with pre-2.4 GTK+, and it was 
broken before my changes and Ulf's changes, it'll probably break again 
at some point.  Given the relatively recent bug report, I'll won't 
*deliberately* break it (i.e., remove the support) in the near future, 
but it's something to consider at some point.