Wireshark-dev: Re: [Wireshark-dev] Should we support GTK+ 2.0[.x] and 2.2[.x], or just 2.4 and
From: Ulf Lamping <[email protected]>
Date: Mon, 21 Apr 2008 04:05:24 +0200
Guy Harris schrieb:
The SVN trunk of Wireshark has had the GTK+ 1.2[.x]/GLib 1.2[.x] support removed. There's still code in there that checks for GTK+ releases prior to 2.4; however:
	1) I checked in a fix to the configure script and to gtk/file_dlg.c 
that prevented Wireshark from compiling on GTK+ 2.2.4/GLib 2.2.3

	2) even with that change, it still fails with

main_toolbar.c: In function 'toolbar_new':
main_toolbar.c:447: error: 'colorize_24_xpm' undeclared (first use in this function)
main_toolbar.c:447: error: (Each undeclared identifier is reported only once
main_toolbar.c:447: error: for each function it appears in.)
main_toolbar.c:451: error: 'autoscroll_24_xpm' undeclared (first use in this function)
	   because neither colorize_24_xpm nor autoscroll_24_xpm are defined 
(with GTK+ 2.4 and later, the macro being used there ignores the xpm 
These errors are a side effect of the recent GTK1.x code cleanup.

I've cleaned up that file so it no longer uses xpm at all. At least this file builds again on 2.0/2.2 - but I don't have a system to test further GTK 2.0/2.2 compilation.
The GTK+ site's page for downloading source:


has links going back to 2.4, as well as a 1.2[x.] link, but no links for earlier versions.
Has anybody build Wireshark with a pre-2.4 release recently?  If not, 
are there enough systems out there with pre-2.4 releases for us to spend 
any time cleaning up the code to build with them?  If not, should we 
just get rid of the code to support pre-2.4 releases?
I don't know about the various unix systems, but the win32 port usually uses the more or less latest GTK release - so no problems dropping pre-2.4 stuff from that side.
However, a quick search for


results in 69 matches, most 2.4, some2.6 (gtk_file_chooser) and one 2.9 (gtk-label-select-on-focus)

So there are not that many places that could show problems here - the problem we have seems to be a lack of tests if GTK 2.0/2.2 is still running.
Of course, if no one uses these versions, it doesn't make a lot of sense 
to maintain them ;-)
Regards, ULFL