Wireshark-dev: Re: [Wireshark-dev] 0.99.5 and 0.99.7 incompatibility
From: Guy Harris <[email protected]>
Date: Thu, 17 Apr 2008 17:13:51 -0700
On Apr 17, 2008, at 4:37 PM, MKS {} wrote:

I compiled against the 0.99.5 header files and run with the 0.99.5 version of wireshark,
the protocol column gets updated with the correct info.

However, when I use the same plugin with 0.99.7 version of wireshark, the protocol column shows "UDP" (which is the lower layer protocol. Any idea what is going on?
What's going on is that we don't currently guarantee that the COL_  
values will remain unchanged from release to release, and thus we  
don't guarantee that plugin binaries will work from release to  
release.  We also don't currently guarantee that anything *else* about  
the binary interface for plugins will remain unchanged from release to  
release (in fact, there's an excellent chance that it won't remain  
unchanged between Wireshark 1.0 and the next Wireshark release), so  
you'll need to recompile your plugin to work with a release other than  
0.99.5.
At some point, we hope to have a stable binary interface.  However,  
that binary interface had better then be one we're willing to live  
with forever, and I suspect we don't consider the current interface  
one we're willing to live with forever (I certainly don't).