Wireshark-dev: Re: [Wireshark-dev] dll works with Wireshark0.99.6a but not with Wireshark0.99.7
From: "A Verma" <[email protected]>
Date: Thu, 28 Feb 2008 10:47:33 +0530
Thanks Stephen!
I did that but I am getting the following errors(My dll is called xxx.dll):
plugin.c
Generating Code...
       ...
   Creating library ciscosm.lib and object ciscosm.exp
        cd ..
        cd xxx
        "C:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe" /
          -f Makefile.nmake

Microsoft (R) Program Maintenance Utility Version 8.00.50727.762
Copyright (C) Microsoft Corporation.  All rights reserved.

Making plugin.c (using python)
        sed -e s/@[email protected]/xxx/  -e s/@[email protected]/0,6,5,0/  -e s/@RC
[email protected]/0,99,9,0/  -e s/@[email protected]/0.6.5.0/  -e s/@[email protected]/xxx/  -e s/@
[email protected]/0.99.9"-xxx-yyy-01"/  -e s/@[email protected]/MSVC2005EE/  < plugin.rc.in >
 xxx.rc
        rc  /r xxx.rc

xxx.rc(5) : error RC2167 : unrecognized VERSIONINFO field;  BEGIN or comma expected
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\BIN\rc.EXE"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe"' : return code '0x2'
Stop.

What mismatch is there between versions? Pls help me.

Thanks!

regards,

Ash


 
On 2/28/08, Stephen Fisher <[email protected]> wrote:

On Thu, Feb 28, 2008 at 10:06:23AM +0530, A Verma wrote:

> I installed both the wireshark versions one by one and used the dll by
> putting it in the plugins folder. It worked with Wireshark0.99.6a but
> not with Wireshark0.99.7.
>
> I am trying to recompile the dll with Wireshark0.99.7.
>
> I am on the right path? Pls advice.

Yes, it needs to be compiled with each version you intend to use it
with.  So compile it with 0.99.7 sources for use in 0.99.7.


Steve