Wireshark-dev: Re: [Wireshark-dev] need help : NSIS
From: Ulf Lamping <[email protected]>
Date: Sat, 23 Feb 2008 00:18:35 +0100
Pascal Heude schrieb:
Hi,

I had the same problem than bijjou200 and I found the following solution :

- edit the config.nmake file (the one in the installation directory of wireshark)
- copy the following line
VCREDIST_EXE=$(WIRESHARK_LIBS)\vcredist_x86.exe
between the following 2 lines (in the section "C-Runtime Redistributable"
!ELSEIF "$(MSVC_VARIANT)" == "MSVC2005"
and
MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 8\VC\redist\x86\Microsoft.VC80.CRT\*.*
- finally put in comment the line (the previous one)
MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 8\VC\redist\x86\Microsoft.VC80.CRT\*.*
I have choosen to modify the part "MSVC2005" of the section "C-Runtime 
Redistributable" because I am currently using this compiler. If you 
get the same problem with another compiler, you should choose the part 
according to your compiler.
Hmmm, are you sure, you've just simply set the MSVC_VARIANT setting wrong?!?

There is a difference between:

MSVC_VARIANT=MSVC2005

and

MSVC_VARIANT=MSVC2005EE


When I'm using the MSVC2005 setting on my Express Edition environment, I'm getting exactly the same error as described.
Regards, ULFL

P.S: I've added a message to the NSIS script output, "if the following is getting wrong, check MSVC_VARIANT" to avoid problems in the future.