Wireshark-dev: Re: [Wireshark-dev] Bug 2066: GtkCombo: Conversion Status
From: Sake Blok <[email protected]>
Date: Tue, 29 Jan 2008 11:42:39 +0100
On Tue, Jan 29, 2008 at 09:31:52AM +0100, Anders Broman wrote:
> On Mon, Jan 28, 2008 at 11:14:19AM -0500, Bill Meier wrote:
> >> Ulf Lamping wrote:
> >> > This seems to be a bug in the GTK libraries, we should simply "go
> back" 
> >> > to the old GTK version that works and put some pressure on the GTK 
> >> > guys (the bug report seems to be written already).
> >> 
> >> Bottom Line:
> >> 
> >> I now think the right answer is to follow Ulf's suggestion to fall 
> >> back to the GTK version currently being used with 0.99.7 and to push 
> >> to get the GTK problem fixed (or a work-around determined).
> >
> >+1 for me
>
> >Can someone bump the GTK version back to GTK+ 2.12.1 with GLib 2.14.3
> which seems to be the last combination on windows that doesn't have this
> problem?
> 
> The way to do that would be to switch the Tag used in win32-setup.sh to
> the tag used for the 0.99.7 release
> then the top level makefile.nmake and config.nmake has to be changed
> accordingly...

Thanks for this help. I have taken a look into the changes that were
made to these three files in SVN 23674. Most of the changes seem to
be for the updated version of gettext. I suspect I can leave them in?

I will change the versions to GTK+ 2.12.1 with GLib 2.14.3 on trunk
and will watch the buildbot to make sure it doesn't break anything 
else...

Cheers,
    Sake