Wireshark-dev: Re: [Wireshark-dev] sed related error while building wireshark (0.99.7 version)
From: "khushbu thakkar" <[email protected]>
Date: Sat, 5 Jan 2008 16:39:49 +0530
Hello Vikas,
 
          I m getting the same build errors as u mentioned. Can u please elaborate how did u rectified the error to build wireshark successfully.
 
Thanxs in Advance,
Reply Soon,
Khushbu
 
On 12/26/07, Vikas Jain <[email protected]> wrote:
I was not pointing to the correct sed program in my environment settings. After I rectified that, I was able to build the wireshark successfully.
 
Thanks,
Vikas


 

From: [email protected]
To: [email protected]
Date: Wed, 26 Dec 2007 05:01:37 +0000
Subject: [Wireshark-dev] sed related error while building wireshark (0.99.7 version)


Hi,
 
I am setting up the environment on my Windows machine to build Wireshark. I am following instructions as per
section 2.2 of the developer's guide. All the tool installation looks good and the tool verification by the nmake
also looks good. I have downloaded the sources for 0.99.7 version locally onto my machine.
 
However, when I kick-start the build for wireshark using "nmake -f Makefile.nmake all", I get the following error:
 
=====================================
 
C:\wireshark-0.99.7>nmake -f Makefile.nmake all
Microsoft (R) Program Maintenance Utility Version 8.00.50727.42
Copyright (C) Microsoft Corporation.  All rights reserved.
        "C:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe" /
          -f Makefile.nmake WIN32_SETUP_OPT=--libverify process_libs
Microsoft (R) Program Maintenance Utility Version 8.00.50727.42
Copyright (C) Microsoft Corporation.  All rights reserved.
        if not exist C:\wireshark-win32-libs md C:\wireshark-win32-libs
Wireshark is ready to build.
        sed -e s/@[email protected]/0.99.7a/  -e "s/@[email protected]/#define HAVE_GNU_ADNS
 1/"  -e " s/@[email protected]/#define HAVE_LIBPCRE 1/"  -e "s/@[email protected]/#define HAVE_
MIT_KERBEROS 1/"  -e " s/@[email protected]//"  -e " s/@[email protected]/#define HAVE_LIBZ 1/
"  -e "s/@[email protected]/#define HAVE_LIBPCAP 1/"  -e " s/@[email protected]/
#define HAVE_PCAP_FINDALLDEVS 1/"  -e " s/@[email protected]/#defin
e HAVE_PCAP_DATALINK_NAME_TO_VAL 1/"  -e " s/@[email protected]/#de
fine HAVE_PCAP_DATALINK_VAL_TO_NAME 1/"  -e "s/@[email protected]// "  -e "s/@
[email protected]/#define HAVE_LIBWIRESHARKDLL 1/"  -e "s/@WPCAP_CONSTIFIED @
/#define WPCAP_CONSTIFIED 1/"  -e "s/@[email protected]/#define HAVE_LIBGNUTLS 1/"
  -e "s/@[email protected]/#define HAVE_LIBGCRYPT 1/"  -e " s/@[email protected]/#define HA
VE_LUA 1/"  -e "s/@[email protected]/#define HAVE_LUA_5_1 1/"  -e " s/@[email protected]/
#define HAVE_AIRPCAP 1/"  -e " s/@[email protected]/#define HAVE_AIRPDCAP 1/"  -e "s
/@[email protected]/#define HAVE_LIBPORTAUDIO 1/"  -e " s/@[email protected]//"
-e "s/@[email protected]/#define HAVE_LIBSMI 1/"  < config.h.win32 > config.h
sed: Unterminated `s' command
NMAKE : fatal error U1077: 'sed' : return code '0x1'
Stop.
=============================================
 
Any ideas if I am missing something? Any help would be appreciated.
 
 
Thanks,
Vikas
 
 


Post free auto ads on Yello Classifieds now! Try it now!


It's about getting married. Click here! Try it!

_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev