Wireshark-dev: Re: [Wireshark-dev] wireshark 0.99.7 crash on MacOS X 10.5 (Leopard)
From: Michael Tuexen <[email protected]>
Date: Thu, 3 Jan 2008 22:58:15 +0100
On Jan 3, 2008, at 9:54 PM, Andreas Fink wrote:

I was able to successfully build wireshark with
the latest gtk/glib stuff. Everything works fine
except for the stock icons...
I dont know which Icons you refer to but on my Mac i'm not missing
any...
Hmmm. The New, Open, and so on icons in the toolbar. I used
gtk-2.12.3.

I've built it with the following packages on i386
I tried a minimalistic approach:

adns-1.3
No.
atk-1.20.0
1.9.2
cairo-1.4.12
Same.
gettext-0.17
Same.
glib-2.15.0
2.14.4
gtk+-2.12.3
Same.
jpeg-6b
No.
libpng-1.2.24
No, there is already a version in /usr/X11/lib/
lua-5.1.2
No.
pango-1.19.0
1.18.0
pcre-7.4
No.
pkg-config-0.22
Same.
portaudio (pa_stable_v19_20071207.tar.gz)
None.
tiff-3.8.2
None.
wireshark-0.99.7
svn

it says:

Compiled with GTK+ 2.12.3, with GLib 2.15.0, with libpcap 0.9.5, with
libz
1.2.3, with libpcre 7.4, without SMI, with ADNS, with Lua 5.1, without
GnuTLS,
without Gcrypt, with MIT Kerberos, with PortAudio PortAudio V19-devel
(built Jan
 2 2008), without AirPcap.
Running on Darwin 9.1.0 (MacOS 10.5.1), with libpcap version 0.9.5.
Built using gcc 4.0.1 (Apple Inc. build 5465).

The gtk+ stock icons are in .png format in gtk/stock-icons.

I also tried with installing the libpng lib, but it does not affect
the problem I have.
I'm publishing the i386 installers tonight after testing it.



_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev