Wireshark-dev: Re: [Wireshark-dev] column_info.h rev 23058 introduce a bug for plugins?
From: "Sake Blok" <[email protected]>
Date: Wed, 10 Oct 2007 11:29:14 +0200
Title: Message
Hi Antoine,
 
Sorry for breaking your plugin-distribution, but it has been my understanding that all plugins need to be compiled against the sources of the version you want to use them with. So every Wireshark version has it's own plugin-binaries. If sometimes plugins can be used with multiple Wireshark-versions, it's luck, because the current API does not guarantee it.
 
The reason for putting the new column-options in the middle of the enums is that they logically fit there. I would prefer to keep them there.
 
Cheers,
 
 
Sake
----- Original Message -----
Sent: Wednesday, October 10, 2007 11:07 AM
Subject: [Wireshark-dev] column_info.h rev 23058 introduce a bug for plugins?

Hi,
 
I'm writting a plugin for a specific protocol of my company and I found that a recent change to the file column_info.h (rev 23058) introduce an issue with the check_col function when the plugin is used with a previous version of wireshark (ie 0.99.6).
 
The change had added two new columns in the middle of the enum and so COL_PROTOCOL and COL_INFO have been shifted two times.
 
So if the plugin is compiled with the latest release of the repository, the check_col function will return false in all previous version of wireshark.
 
I think that the two new columns in the enum should be added at the end of the list and not in the middle of it ?
 
Thanks for your help.
Antoine


_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev