Wireshark-dev: Re: [Wireshark-dev] Adding Capture Engine question
From: "Audet, Jean-Michel" <[email protected]>
Date: Tue, 28 Aug 2007 14:55:14 -0400
I have another questions,

I don't know why but sometimes the function pcap_platform_finddevs is not called so my i2c device is not found.  If I enter the name of the interface manually, it works.

Any idea?

Thanks!
JM



-----Message d'origine-----
De : [email protected] [mailto:[email protected]] De la part de Luis EG Ontanon
Envoyé : Friday, August 24, 2007 10:44 AM
À : Developer support list for Wireshark
Objet : Re: [Wireshark-dev] Adding Capture Engine question

This (I think) is related to
http://bugs.wireshark.org/bugzilla/show_bug.cgi?id=1757
can you download a recent snapshot and verify if it gets rid of the problem?

if not can you open a bug for it?

Thanks

On 8/24/07, Audet, Jean-Michel <[email protected]> wrote:
>
>
>
>
> Hi,
>
>             I am currently adding a capture engine to sniff i2c traffic.
>
>
>
> I am currently adding this code into Linux using the pcap_linux mechanism
> (like Bluetooth and USB).
>
>
>
> My question is (and I am not currently sure if it's Wireshark or libpcap)
> why do I get calls to my function xx_open_live each seconds (approx) during
> my capture.
>
>
>
> I get calls to the function xx_read to get the packets but I was expecting a
> call to the xx_open_live function only once when the capture starts and a
> call to the function xx_close at the end.  My monitoring external hardware
> cannot be start and stop without loosing packets.
>
>
>
> Thanks for your help!
>
>
>
> JM
>
>
> _______________________________________________
> Wireshark-dev mailing list
> [email protected]
> http://www.wireshark.org/mailman/listinfo/wireshark-dev
>
>


-- 
This information is top security. When you have read it, destroy yourself.
-- Marshall McLuhan
_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev