Wireshark-dev: Re: [Wireshark-dev] [Wireshark-commits] rev 21452: /trunk/epan/dissectors/ /trun
From: "Martin Mathieson" <[email protected]>
Date: Tue, 17 Apr 2007 17:31:02 +0100
Hi,

My build is failing to link from this revision onwards.  The error
output is the following:

gcc -DINET6 "-D_U_=__attribute__((unused))" -Wall -Wpointer-arith -W
-g -O2 -Wdeclaration-after-statement -I/usr/local/include -DXTHREADS
-D_REENTRANT -DXUSE_MTSAFE_API -I/opt/gnome/include/gtk-2.0
-I/opt/gnome/lib/gtk-2.0/include -I/usr/X11R6/include
-I/opt/gnome/include/atk-1.0 -I/opt/gnome/include/pango-1.0
-I/usr/include/freetype2 -I/usr/include/freetype2/config
-I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib/glib-2.0/include -o
.libs/wireshark capture-pcap-util-unix.o capture_errs.o
capture-pcap-util.o capture_stop_conditions.o capture_ui_utils.o
cfile.o clopts_common.o conditions.o disabled_protos.o packet-range.o
print.o ps.o pcapio.o ringbuffer.o timestats.o util.o version_info.o
airpcap_loader.o alert_box.o capture.o capture_info.o capture_opts.o
capture_sync.o color_filters.o file.o fileset.o filters.o g711.o
merge.o proto_hier_stats.o sync_pipe_write.o summary.o tempfile.o
.libs/wiresharkS.o -Wl,--export-dynamic -Wl,--export-dynamic
-L/usr/local/lib gtk/libui.a codecs/libcodec.a
wiretap/.libs/libwiretap.so -L/opt/gnome/lib
epan/.libs/libwireshark.so -L/usr/lib -lpcap -pthread
/opt/gnome/lib/libgtk-x11-2.0.so /opt/gnome/lib/libgdk-x11-2.0.so
/opt/gnome/lib/libatk-1.0.so /opt/gnome/lib/libgdk_pixbuf-2.0.so -lm
/opt/gnome/lib/libpangoxft-1.0.so /opt/gnome/lib/libpangox-1.0.so
/opt/gnome/lib/libpango-1.0.so /opt/gnome/lib/libgobject-2.0.so
/opt/gnome/lib/libgmodule-2.0.so -ldl /opt/gnome/lib/libgthread-2.0.so
-lpthread /opt/gnome/lib/libglib-2.0.so /usr/lib/libgnutls.so
/usr/lib/libgcrypt.so -lnsl /usr/lib/libgpg-error.so -lz
epan/.libs/libwireshark.so: undefined reference to `.LC1698'
epan/.libs/libwireshark.so: undefined reference to `.LC1695'
epan/.libs/libwireshark.so: undefined reference to `.LC1694'
epan/.libs/libwireshark.so: undefined reference to `.LC1692'
epan/.libs/libwireshark.so: undefined reference to `.LC1697'
epan/.libs/libwireshark.so: undefined reference to `.LC1696'
epan/.libs/libwireshark.so: undefined reference to `.LC1693'
collect2: ld returned 1 exit status


I recently updated my version of gcc from 3.4.3 -> 3.4.6.  Here is the
version info from Help | About Wireshark :


Compiled with GTK+ 2.4.9, with GLib 2.4.6, with libpcap 0.8.3, with libz 1.2.1,
without libpcre, without Net-SNMP, without ADNS, without Lua, with GnuTLS
1.0.13, with Gcrypt 1.2.0, without Kerberos, without PortAudio, without AirPcap.
NOTE: this build doesn't support the "matches" operator for Wireshark filter
syntax.

Running on Linux 2.6.8-24-smp, with libpcap version 0.8.3.

Built using gcc 3.4.6.



I wondered if maybe I had some libraries built with the older version
of the compiler, but I don't see anything in the diff that suggests it
would pull in any more library code than before.  Going back to the
earlier version of the compiler isn't an easy option (but I will do if
no-one else has the same problem...).  Any ideas?

Best regards,
Martin

On 4/17/07, [email protected] <[email protected]> wrote:
http://anonsvn.wireshark.org/viewvc/viewvc.cgi?view=rev&revision=21452

User: gerald
Date: 2007/04/17 12:34 AM

Log:
 More .11k/n updates from Dustin Johnson:

   - Measurement Pilot frame support
   - Various Block Ack fields
   - Various Power fields
   - Measurement Pilot field
   - Country String field
   - Channel Width field
   - QoS Information fields

Directory: /trunk/epan/dissectors/
  Changes    Path                  Action
  +1025 -394 packet-ieee80211.c    Modified

_______________________________________________
Wireshark-commits mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-commits