Wireshark-dev: Re: [Wireshark-dev] U3 package fails to install
From: Clifford Thrasher <[email protected]>
Date: Fri, 06 Apr 2007 12:27:47 -0400
Graham Bloice wrote:
Graeme Lunt wrote:
  
Hi,

    
Graham Bloice wrote:
      
I built a U3 version from SVN 20915, but the resulting .u3p fails to
install on my SanDisk MicroCruzer.
        
Does the package downloaded from:
http://prdownloads.sourceforge.net/wireshark/wireshark-0.99.5.u3p

install OK?

    
Yes it does, without an icon as has been discussed previously.

  
When I run the U3 add programs applet, it reports:

U3 Launchpad failed to install U3 program, due to a 
possible error in the program package.  Try downloading and installing 
the program again.
If the problem persists, contact the program software vendor.

The version of U3 Launchpad in use is 1.4.0.2

        
I'm also unable to install either a home built version from the latest
SVN (20933) or the buildbot version of the same.
      
I have seen this sort of error when the manifest.u3i file is corrupt. 

Have a look at the file in packaging/u3/win32/manifest - or extract it from
the u3p using a zip tool.
Does it look OK?

    
The one in my working copy looks fine, it seems to be well formed XML, I
assume the actual content is correct.

  
Hi Graham, I know its been over a month, but I tried to build a U3 package myself and ran into the same error.  I fixed it by going into the packaging\u3\win32 directory once the u3p file is complete, from there I created my own archive.  I added the data, device, host and manifest directories to a zip archive with zero compression.  Then I renamed that zip archive to the desired u3p filename.  The U3 program took the handmade archive with no problems.

Cliff