Wireshark-dev: Re: [Wireshark-dev] build problem
From: "Prokash Sinha" <[email protected]>
Date: Tue, 26 Dec 2006 09:35:35 -0800
No. I was not able to.
 
This is the first time I'm trying to build out of source.
 
I installed the cygwin environment, and the develp env that are required. The problem I see is that the dir. sturct. layout that comes from cygwin is not what this package is expecting.
 
Under both cygwin or windows cmd line, I don't see a smooth build. I did not change any source and or directory structures of the dev env.
 
Have you been able to build the latest trunk after downloding ( I have 0.99, the latest as of 24th dec)
 
-pro

 
On 12/26/06, Jaap Keuter <[email protected]> wrote:
Hi,

Did you already build the setup target?

Thanx,
Jaap

On Mon, 25 Dec 2006, Prokash Sinha wrote:

> I tried that too.
>
> What I was expecting is that if I follow the Developers doc, I should pretty
> much be able to build it, without much reconfigurations.
>
> I installed the cygwin, and all related development stuff from cygwin, so I
> should expect that I don't need to change much in the way.
>
> So there are some PATH problems, even if I do install as instructed.
>
>
> C:\Documents and Settings\psinha\wireshark>nmake -f Makefile.nmake all
>
> Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
> Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
>
>         cd tools
>         NMAKE /                   -f Makefile.nmake
>
> Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
> Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
>
>         cd lemon
>         NMAKE /                   -f Makefile.nmake
>
> Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
> Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
>
>         cd ..
>         cd ..
>         cd image
>         NMAKE /                   -f Makefile.nmake
>
> Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
> Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
>
>         cd ..
>         cd codecs
>         NMAKE /                   -f Makefile.nmake
>
> Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
> Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
>
>         cl -DHAVE_CONFIG_H /IC:\wireshark-win32-libs\glib\include\glib-2.0
> /IC:
> \wireshark-win32-libs\glib\lib\glib-2.0\include -D_U_="" /Zi /W3 -Fd.\ -c
> G711u\
> G711udecode.c -o G711udecode.obj
> Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 12.00.8804 for 80x86
> Copyright (C) Microsoft Corp 1984-1998. All rights reserved.
>
> G711udecode.c
> G711u\G711udecode.c(25) : fatal error C1083: Cannot open include file: '
> glib.h':
>  No such file or directory
> NMAKE : fatal error U1077: 'cl' : return code '0x2'
> Stop.
> NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual
> Studio\VC98\bin\N
> MAKE.EXE"' : return code '0x2'
> Stop.
> If I fix this I will get other compilation issues.
>
> Essentially I hope that I don't have to go for a lot of config changes !
>
> -pro
>
>
> On 12/25/06, Jaap Keuter <[email protected]> wrote:
> >
> > Hi,
> >
> > Build from a command prompt, not from Cygwin Bash shell.
> >
> > Thanx,
> > Jaap
> >
> > On Sun, 24 Dec 2006, Prokash Sinha wrote:
> >
> > > I've been able to get back to automake 1.6, but autoconf seems to be
> > sticky.
> > > ( Not sure if it is a dependency). I can't seem to uninstall this. Also
> > > there seem to be no autconf 2.52 on cygwin.com auto installation !
> > >
> > >  By the way the problem is still there with automake 1.6 and autoconf
> > 2.60
> > >
> > > -pro
> > >
> > >
> > > On 12/24/06, Stephen Fisher < [email protected]> wrote:
> > > >
> > > > On Sun, Dec 24, 2006 at 06:08:30PM -0800, Prokash Sinha wrote:
> > > >
> > > > > I checked thru the environment ( as per the document: Developers
> > > > > guide) to see all the required dev tools are installed correctly.
> > > >
> > > > > [email protected] ~/wireshark
> > > > > $ python -V
> > > > > Python 2.4.3
> > > >
> > > > Python 2.4.3 is what I use successfully.
> > > >
> > > > > What could be the problem in my configuration ?
> > > >
> > > > What version of automake and autoconf are you using?  (automake
> > > > --version and autoconf --version).  I am using automake 1.6 and
> > autoconf
> > > > 2.52.  I've had strange problems with some of the other versions.
> > > >
> > > >
> > > > Steve
> > > > _______________________________________________
> > > > Wireshark-dev mailing list
> > > > [email protected]
> > > > http://www.wireshark.org/mailman/listinfo/wireshark-dev
> > > >
> > >
> >
> > _______________________________________________
> > Wireshark-dev mailing list
> > [email protected]
> > http://www.wireshark.org/mailman/listinfo/wireshark-dev
> >
>

_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev