Wireshark-dev: Re: [Wireshark-dev] This application has failed to start because wiretap-0.3.dll
From: "Robert Trybis" <[email protected]>
Date: Mon, 13 Nov 2006 15:19:34 -0000
Yes! Running from wireshark-gtk2 means the dll is found.
I have managed build the system and capture data.

Thanks
RT

> -----Original Message-----
> From: [email protected] [mailto:wireshark-dev-
> [email protected]] On Behalf Of Ulf Lamping
> Sent: 12 November 2006 16:59
> To: Developer support list for Wireshark
> Subject: Re: [Wireshark-dev] This application has failed to start
because
> wiretap-0.3.dll was not found
> 
> Robert Trybis wrote:
> >
> > Under XP I have built wireshark.exe from release 0.99.4
> >
> > When I try to run the programme I get a popup titled "wireshark.exe
-
> > Unable to Locate Component" with the message
> >
> > "This application has failed to start because wiretap-0.3.dll was
not
> > found. Re-installing the application may fix the problem."
> >
> > I can see copies of wiretap-0.3.dll in three directories;
> >
> > wiretap
> >
> > wireshark-gtk1
> >
> > wireshark-gtk2
> >
> > These appear to have been created by the build, they are all the
same
> > size, and all have the same modification date/time so I am presuming
> > they are identical.
> >
> > How does wireshark locate the dlls?
> >
> > Should the build be registering the dlls?
> >
> > Any ideas how to fix this?
> >
> You need to run wireshark from the wireshark-gtk2 dir, it contains the
> complete environment (dlls and such).
> 
> Regards, ULFL
> _______________________________________________
> Wireshark-dev mailing list
> [email protected]
> http://www.wireshark.org/mailman/listinfo/wireshark-dev