Wireshark-dev: Re: [Wireshark-dev] Anyone of the developers going to support Win98 (and alike)
From: Andreas Fink <[email protected]>
Date: Mon, 28 Aug 2006 10:25:36 +0200

On 28.08.2006, at 10:13, Ulf Lamping wrote:

Andreas Fink wrote:
To give you an example what you have to maintain for GTK2 on MacOS X.
This is the list of dependent packages to link to for GTK2 under MacOS X 

    atk1
    atk1-shlibs
    gettext-bin
    gettext-dev
    gettext-tools
    glib2
    glib2-dev
    glib2-shlibs
    gtk+2
    gtk+2-dev
    gtk-doc
    libiconv
    libiconv-dev
    libpcap
    libpcap-shlibs
    libjpeg
    libjpeg-shlibs
    libpng3
    libpng3-shlibs
    libtiff
    libtiff-shlibs
    pango1-xft2-dev
    pcre
    pcre-shlibs
    pkgconfig
    x11-dev
    x11-shlibs
    xft2-dev
    xft2-shlibs

while the same with GTK1 is
   glib-1.2
   gtk+1.2


Normal users have none of them installed
That's mostly the same amount on windows, we'll ship (most) of these 
libraries included in the installer.

However, I think that libpcap and pcre are also needed for the GTK1 build.

libpcap is a dependency of ethereal/wireshark in general. So its true for GTK1 as well as GTK2 version.
Apple ships libpcap.dylib with MacOS X by default. So no other version has to be built with it.
pcre I dont know even what it is. its for sure not needed on MacOS X.




Andreas Fink
Fink Consulting GmbH
---------------------------------------------------------------
Tel: +41-61-6666332 Fax: +41-61-6666331  Mobile: +41-79-2457333
Address: Clarastrasse 3, 4058 Basel, Switzerland
---------------------------------------------------------------
ICQ: 8239353
MSN: [email protected] AIM: smsrelay Skype: andreasfink
Yahoo: finkconsulting SMS: +41792457333