Wireshark-dev: [Wireshark-dev] Anyone of the developers going to support Win98 (and alike) any
From: Ulf Lamping <[email protected]>
Date: Sat, 26 Aug 2006 14:32:17 +0200
Hi List!

The current situation of Win98/95/ME (and Nt 4.0) support is unsatisfactory IMHO.
Telling our users "it may or may not work" isn't very nice if we really 
now that it won't work and certainly will never work anymore in the future.
Our current Wireshark releases 0.99.2 / 0.99.3 won't work with Win9x at 
all, because of the Unicode problems,
see bug 964: http://bugs.wireshark.org/bugzilla/show_bug.cgi?id=964

However, there are other problems here as well:

- GTK2.8 (and higher) definitely won't even work with 9x
- WinPcap no longer actively supports Win9x (so it may or may not work)
- Microsoft don't support 9x any longer

I would guess, that the situation with NT 4.0 is very similar.


Is there any developer willing to support Win9x based systems any longer?
This wouldn't be too much effort, but there's a lot of other work left and I don't have the time and motivation to support these old systems myself.
If there's no one else willing to support these systems, we should 
officially drop the support and note this in the documentation, wiki and 
elsewhere.
This will enable us to switch the Win32 GTK version to the latest 2.8.20 
without any hassle,
as this *may* fix some GUI related problems (or at least enables us to 
write bugreports against the latest available Win32 GTK version).
Regards, ULFL

P.S: Telling our users (in the documentation) that Ethereal 0.99.0 (which includes WinPcap 3.1) was the last known version to work with Win 9x is a good idea IMHO.