Wireshark-dev: Re: [Wireshark-dev] Solaris buildbot complains about zlib
From: Gerald Combs <[email protected]>
Date: Mon, 14 Aug 2006 15:25:36 -0500
Jaap Keuter wrote:
> Hi Gerald,
> 
> This is from the configure log of the Solaris buildbot:
> ......
> checking whether to use zlib for reading compressed capture files... yes
> checking zlib.h usability... yes
> checking zlib.h presence... yes
> checking for zlib.h... yes
> checking for gzgets in -lz... yes
> checking for gzgets missing when linking with X11... yes
> configure: error: old zlib found when linking with X11 - get rid of old zlib.
> program finished with exit code 1
> 
> Maybe you can help it along.

It looks like the auto* packages needed to be updated.  Fixing that
turned up another problem, however:

/bin/bash ../../libtool --tag=CC --mode=link gcc
-D_U_="__attribute__((unused))" -Wall -Wpointer-arith -W  -g -O2
-Wno-return-type -DFUNCPROTO=15 -I/usr/local/include -D_REENTRANT
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -I/opt/csw/include -I/opt/csw/include
-L/usr/local/lib -R/usr/local/lib -L/opt/csw/lib -R/opt/csw/lib
-L/opt/csw/lib -L/usr/local/lib -R/usr/local/lib -o acn.la -rpath
/usr/local/lib/wireshark/plugins/0.99.3-SVN-18895 -module -avoid-version
plugin.lo packet-acn.lo  -L../../epan -lwireshark -lgmodule-2.0 -ldl
-lglib-2.0
grep: can't open
"/export/home/calmeida/build/net-snmp-5.3.0.1/cswstage/opt/csw/lib/libnetsnmp.la"
/opt/csw/bin/gsed: can't read
/export/home/calmeida/build/net-snmp-5.3.0.1/cswstage/opt/csw/lib/libnetsnmp.la:
No such file or directory
libtool: link:
`/export/home/calmeida/build/net-snmp-5.3.0.1/cswstage/opt/csw/lib/libnetsnmp.la'
is not a valid libtool archive

Hopefully it won't be too hard to fix.