Wireshark-dev: Re: [Wireshark-dev] cannot compile on OpenBSD 3.9
From: Richard Johnson <[email protected]>
Date: Tue, 18 Jul 2006 01:30:48 +0000 (UTC)
Randall <[email protected]> writes:

> 
> I'm compiling on OpenBSD 3.9
> ...
> /usr/bin/ld: cannot find -lwiretap


See http://www.linbsd.org/ethereal_on_openbsd38.html

I'm currently testing a conversion of that for OpenBSD-current (as of 2006-07)
and the latest wireshark versions.  The ports I made using Ober Heim's (above)
as the starting point are here:

http://www.cisl.ucar.edu/dsg/grp-mem/rjohnson/wireshark-0.99.1pre1-openbsd-port.tgz
http://www.cisl.ucar.edu/dsg/grp-mem/rjohnson/wireshark-0.99.2pre1-openbsd-port.tgz
and
http://www.cisl.ucar.edu/dsg/grp-mem/rjohnson/wireshark-0.99.2-openbsd-port.tgz

The package that results installs and removes cleanly, and the binaries work. 
However, I haven't reviewed the patches included in my version port beyond
editing them so they'd apply, so caveat emptor.


Richard